I'm pretty sure this isn't a duplicate. Do you use #pragma mark? I've seen multiple ways, which is correct?
#pragma mark -
#pragma mark === Actions ===
#pragma mark -
#pragma mark -
#pragma mark === Actions ===
#pragma mark - === Actions ===
#pragma mark Actions
What is the way you do it? How do you suggest dividing it up? What do you normally name your sections, for say, a view controller?
There is no "Correct" way, it is annotation, so how you use it is a coding style issue.
Having said that, I do:
#pragma mark -
#pragma mark Actions
Because that causes the popup menu in the Xcode editor group the title and the methods inside of the same divider.