Top "Naming-conventions" questions

Naming conventions refer to general rules governing names assigned to programming constructs such as variables and methods.

What strategy do you use for package naming in Java projects and why?

I thought about this awhile ago and it recently resurfaced as my shop is doing its first real Java web …

java naming-conventions packages
Standard File Naming Conventions in Ruby

For a file containing the given class, SomeCoolClass, what would be the proper or standard filename? 1. somecoolclass.rb 2. some_cool_…

ruby file naming-conventions conventions
C# Variable Name "_" (underscore) only

I was just hit with a minor issue in C#, it was just a copy-paste mistake but don't know how …

c# naming-conventions identifier
What does the dot mean in R – personal preference, naming convention or more?

I am (probably) NOT referring to the "all other variables" meaning like var1~. here. I was pointed to plyr once …

r coding-style naming-conventions plyr
Swift: Global constant naming convention?

In Swift, it seems that global constants should be camelCase. For example: let maximumNumberOfLoginAttempts = 10 Is that correct? I'm used to …

naming-conventions constants swift global
Naming cookies - best practices

What should cookie names look like? Should they be: lower_case CamelCase Underscore_Camel_Case UPPER_CASE Or should they …

php cookies naming-conventions
What's the word for "Enable/Disable"?

When I want to comment code about control Enable/Disable and when I want to discuss with people about the …

naming-conventions terminology
Naming convention for private fields

First, I know this question has been asked several times before and that in the end, it is mostly a …

c# naming-conventions private-members
Should I stop fighting Visual Studio's default namespace naming convention?

I'm working on an MVVM project, so I have folders in my project like Models, ViewModels, Windows, etc. Whenever I …

c# visual-studio naming-conventions namespaces
What's your convention for typedef'ing shared_ptr?

I'm flip-flopping between naming conventions for typedef'ing the boost::shared_ptr template. For example: typedef boost::shared_ptr<Foo&…

c++ boost naming-conventions shared-ptr