Given this scenario where you have "transfer objects" (POJO's with just getters/setters) which are passed by a client library to your API, what is the best way to name the transfer objects?
package com.x.core;
public class Car {
private String make;
private String model;
public Car(com.x.clientapi.Car car) {
this.make = car.getMake();
this.model = car.getModel();
}
}
In this example your main class and your transfer object both have the name Car
. They are in different packages but I think it's confusing to have the same name. Is there a best practice on how to name the transfer objects?
Data Transfer Object classes should follow the name convention defined in the Java Language Specification:
Names of class types should be descriptive nouns or noun phrases, not overly long, in mixed case with the first letter of each word capitalized.
ClassLoader SecurityManager Thread Dictionary BufferedInputStream
[...]
Suffixing a class name with DTO or Dto is not really meaningful and doesn't tell much what the class itself represents. So it may be better to use names that describe the purpose of your classes.
Here is a non-exhaustive list of name suggestions you could use:
Note 1: Whether acronyms or all capitalized words should be handled as words or not, I guess it's up to you. Check the Java API and you will find some stumbles like ZipInputStream
/ GZIPInputStream
. Both classes are in the same package and the name convention is not consistent. HttpURLConnection
doesn't show any consistency with acronyms either.
Note 2: Some names listed above were borrowed from this article written by Richard Dingwall (the original article seems to be no longer available, so here's a cached copy from Web Archive).